gmax Community and Support : hardware/operating systems : Interactive 3D Renderer initialization failed
Forum: Posts From:
Browser_ice
Moderator
4022 Posts
1 Product
Interactive 3D Renderer initialization failed
Posted 08-May-2005 4:41 PM

If upon starting your GMAX you get an error message like "Interactive 3D Renderer initialization failed. Please check your device settings by using the -H command line option", don't panic. It's not realy a problem. It is just a warning and it is giving you the solution at the same time.

What does it mean ?  I means that the rendering driver you choose at the beginning isn't able to display correctly on your screen.

What's the solution ?

You can do it in 3 ways :

A) FROM INSIDE GMAX
===================================================
1) click in the top menu CUSTOMIZE
2) in that menu, click PREFERENCES
3) you will get a pop-up with a bunch of of options. Click the top one that says VIEWPORTS
4) in the bottom right corner, click the button CHOOSE DRIVER
5) another pop-up appears with choices of HEIDI, Direct3D and OpenGL. One should already be chosen. Choose another one.
6) click OK then the OK button of the other pop-up
7) if your viewport still doesn't work, try another driver.
8) if after trying all drivers it doesn't work, post a reply here indicating it.


B) FROM OUTSIDE GMAX
=============================================
1) find the shortcut you use click on to execute your GMAX(if you don't have one because you click on the GMAX program icon directly, then do create a shortcut)
2) do a right click on it and choose PROPERTIES in the menu that appeared
3) a pop-up will appear. Click the top tab SHORTCUT
4) in the TARGET field, you will have something like "YOUR DRIVE:\...\GMAX\gmax.exe"
5) before the ending double quote, add -H (dash H)
6) click OK
7) execute your GMAX via that shortcut you have just modified
8) the GMAX logo will appear. Wait a bit ...
9) another pop-up appears with choices of HEIDI, Direct3D and OpenGL. One should already be chosen. Choose another one.
10) click OK then the OK button of the other pop-up
11) if your viewport still doesn't work, try another driver.
12) if after trying all drivers it doesn't work, post a reply here indicating it.

C) NO CLUE ON HOW TO DO SOLUTION A OR B (risky solution so be ware)
=========================================================
1) start a text editor (Notepad will do nicely)
2) open the file ../gmax/gmax.ini
3) do a FIND on "[WindowsState]"
4) the current rendering driver used will be coded as follow following that string of character you found

[WindowState]
GFXType=OpenGL

    or

[WindowState]
GFXType=Direct3D

    or

[WindowState]
GFXType=HEIDI

5) just replace your the value of GFXType by any of the three above that doesn't match what you already have.
6) save the file
7) start GMAX
8) if the screen is weird or blank or whatever, just close GMAX and choose another one.

Strike Ninja
New Poster
4 Posts
RE: Interactive 3D Renderer initialization failed
Posted 14-May-2005 12:24 PM

I don't understand wat you saying in B.
Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 14-May-2005 1:46 PM

It means to modify the shortcut that you use to start GMAX. If you don't know what a shurtcut is, then I suggest you ask whomever installed WIndows on your PC, to do it.

By the way, no need to post 3 messages in less then 15 min. No one is monitoring the forums every minues or hours. We check in once or twice a day.

george60
New Poster
2 Posts
RE: Interactive 3D Renderer initialization failed
Posted 23-Sep-2006 2:56 PM

hey


for option B, the target doesn't have quotes around it


this is the target


C:gmaxgmax.exe


so how would i do the "-H" thing for option B?


thanks


george60
New Poster
2 Posts
RE: Interactive 3D Renderer initialization failed
Posted 23-Sep-2006 2:58 PM

oh and the slashes won't show up in between "C:" and "gmax" and the second "gmax"

Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 26-Sep-2006 9:42 AM

the double quotes is more intended for when you have spaces in any part of the foldernames

By the way, looking at your gmax name, you have an installation problem. The program name is gmax.exe and not gmaxgmax.exe. When you start the gmax installation, just let all default options as is and it should install find.  Also, since there is no '/' after the C:, it makes me curious as to where you copied this C:gmaxgmax.exe thing. To prevent any other surprises, I would recommand you uninstall gmax, reboot and re-install it with all default options (don't change anything). Then you should get a proper installation with a proper gmax.exe name.






cut678
New Poster
2 Posts
RE: Interactive 3D Renderer initialization failed
Posted 09-Apr-2007 1:00 PM

type in what it would look like bec when i go to put -H in it says its not reconized or watever
rthauter
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 11-Apr-2007 10:37 AM

Just use his option C! It is a piece of cake to do and fixed my problem easily.
fsx flyer
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 03-Jun-2007 2:27 PM

Hello.

I used your example to resolve the 3d render error message, I succeded using the gmx ini file update to opengl.

Thank you. fsx flyer






guba123
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 06-Jun-2007 2:54 AM

ive tried B and C but both of them dont work! I do a FIND and there isnt anything like what you said in the file.
Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 07-Jun-2007 4:53 PM

If you cannot find these inside the file then something is very wrong. Please copy/paste the content of the file here so we can have a look.
fuzzylunkinz
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 18-Jun-2007 9:44 AM

I fixed my problem but I'll help you help others fix it.

I got this same error message, and i tried to do all of these options.

Option A was unavailable because I couldn't actually get into the program.

Option B didn't work because my path didn't have quotes around it (I'm assuming) and it wouldn't let me change it.

Option C SORT of worked.  I went in and there was only one thing there:

[BitmapDirs]
Dir2=C:\gmax\downloads
Dir1=C:\gmax\maps

So I wasjust going to add:

[WindowState]
GFXType=OpenGL

Simple, right?  Not quite.  The file was set to read only.  So I went to Start, Run, Command, went to my gmax directory (type in "cd c:\gmax") and typed in "ATTRIB -R c:\gmax\gmax.ini".  After this I was able to save the program.

About [WinodwState] not being there I think thats a problem with the installation.
cimarronbuilder
New Poster
2 Posts
RE: Interactive 3D Renderer initialization failed
Posted 09-Aug-2007 6:42 PM
Modified by Browser_ice On 04-Jan-2008  3:14 PM

I tried all three drivers, neither of them worked.

cimarronbuilder
New Poster
2 Posts
RE: Interactive 3D Renderer initialization failed
Posted 09-Aug-2007 6:54 PM
Modified by Browser_ice On 04-Jan-2008  3:15 PM

I do not understand option c, or how to do it. Can you help?

hockey822
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 11-Aug-2007 8:18 PM

can you just tell us where u put -h? plz?  all i want to see you say is.." you put -h here:  ............?"  so we know exactly toput the -h.. you say before the ending which means anywhere!
Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 15-Aug-2007 9:57 PM

Cimaron, which part exactly you do not understand ?

What are you capable of doing so far in Plan-C ?
Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 15-Aug-2007 10:03 PM

Hockey, do the following :

1- find wherever your GMAX icon is (the one you click to start GMAX)
2- do a mouse right click on it and choose Property
3- you will see a box with different tabs on its top
4- click the Shortcut tab
5- you will see different places where you can enter text. You should see a box located on the right of Target: , in that box you should have your GMAX.exe location  ex: C:\gmax\gmax.exe or C:\Program files\gmax\gmax.exe
6- click on that box and put your cursort after the gmax.exe
7- add a space and type in -h
8 click the Apply button at the bottom and then click OK button
9- now try to start your GMAX with that same icon by double clicking it

p.s. : on some occasions, you may require to enclose the whole gmax location in double quote because of complicated names

ex: "C:\Program files\gmax\gmax.exe" -h
P. Arnott
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 15-Sep-2007 5:40 PM


Thank you, your example helped me heaps

Peter





trainzfan65
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 23-Sep-2007 3:02 AM



I had the interactive 3d renderer failed problem, fixes A and B would not work for me, A because the program would not open in the first place and B because there were no quotes and also I am running Windows Vista Home Premium. Vista has that many security features so it stops you from doing many things that you take for granted in older windows versions. Anyway. Option C worked fine for me HEIDI was the default driver but I changed to Open GL and Gmax opened up for me.

Thanks to the OP for the instructions.




kdog193
New Poster
8 Posts
RE: Interactive 3D Renderer initialization failed
Posted 12-Oct-2007 3:51 AM
Modified by kdog193 On 12-Oct-2007  3:58 AM

i dont have a gmax.ini file


and i can't do the h comand becuse it comes up with this: the name ...gmax.exe-H specified in the target box is not valid. make sure the path and file name are correct.

thanks who ever that person was that said that they went 2 run in the start menu nd did that so on...

i didn't have the file there present in the install folder but when i run the run thing in the smenu it was there nd it worked






damagemeters
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 15-Nov-2007 8:17 PM


yo thx it works fine for me now... option c is what i did.. i tried option B but i was having the same problems with quotes and stuff.. so guys try option c.

thx





Alphatango2
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 25-Nov-2007 4:49 PM


But when i put the -H the way you said to this pops up...

The name 'C:\gmax\gmax.exe-H' specified in the Target box is not valid.  Make sure the path and file name are correct.

What should i do

Thanks





Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 27-Nov-2007 7:09 PM

Alphatango2,  the '-h' should be placed outside the "" and with a space before it.

Instead of :   'C:\gmax\gmax.exe-H'

It should be :   "C:\gmax\gmax.exe" -h
fan24drr
New Poster
1 Post
RE: Interactive 3D Renderer initialization failed
Posted 30-Dec-2007 4:04 PM
Modified by fan24drr On 30-Dec-2007  4:12 PM

Since I cannot open G MAX I cannot do it inside G MAX. I tried the other 2 but I could not get them to work. The only thing in the gmax.ini file is this:


[BitmapDirs]
Dir2=C:gmaxdownloads
Dir1=C:gmaxmaps

Browser_ice
Moderator
4022 Posts
1 Product
RE: Interactive 3D Renderer initialization failed
Posted 04-Jan-2008 3:17 PM

What happens if you do the shortcut -h method ?

Worst case scenario, just add the followings into your gmax.ini

[WindowState]
GFXType=HEIDI
GFXRenderer=SZB7.hdi
GFXDevice=GDI7.hdi
Size=800 600
Place=88 74
Maximized=1
SaveUIonExit=1
Items per page Page